Zyxel XMG2230-52HP
32-port GbE and 16-port 2.5G PoE L3 Access Switch with 4 10G Uplink
Our Price: $1,699.99
Click here to jump to more pricing!
Overview:
The growing demand for higher wireless bandwidth in small and medium-sized businesses (SMBs) continues to drive wireless technology forward. With WiFi 7 pushing speeds to 2.5Gbps and beyond, a robust infrastructure is essential. Introducing the XMG2230 Series—a line of Multi-Gig Layer 3 Access PoE switches available in 28- and 52-port models. The XMG2230-28HP features PoE-capable 2.5G Multi-Gig ports, while the XMG2230-52HP offers a mix of Gigabit and 2.5G PoE ports. Both models include four additional 10G SFP+ fiber uplinks for highspeed connectivity. Additionally, the unique dual power options—AC and DC— ensures a reliable wired infrastructure for WiFi 7.
![]()
Flexible Multi-Gig port configuration for scalable WiFi 7 rollouts
![]()
High resiliency and stability with dual power source options of internal AC primary, optional external DC backup
![]()
Adaptive PoE power budget with either internal AC power 700W (28HP)/960W (52HP) or external DC power system 1440W (28HP)/2400W (52HP)
High density 802.3at and 802.3bt (60W/port) for more powerful, flexible, and simplified deployments
![]()
NebulaFlex Pro allows you to switch between standalone management and intuitive Nebula cloud managed mode with 1-YEAR Pro Pack bundled
![]()
Tailor-made Networked AV mode brings efficiency to professional AVoIP networking setups and monitoring services
Benefits:
Flexible Multi-Gig port configuration for diversified deployments
The XMG2230-28HP offers PoE-capable 2.5G Multi-Gig ports, while the XMG2230-52HP provides a mix of 1G and 2.5G PoE ports. Both models include four 10G SFP+ fiber uplinks for high-speed connectivity. The 52-port model’s port mix enables efficient bandwidth allocation based on device needs, balancing cost and performance for scalable, future-proof networks.
Scalable Multi-Speed PoE

Scalable Multi-Speed PoE

Dual power for always-on connectivity
The XMG2230 Series is designed with superior network resiliency in mind, featuring dual power sources: an internal AC input as the primary source and an optional DC input for connection to an external DC power system. This active-standby power redundancy enables automatic switchover to backup power if the main AC source fails. The dual power design helps prevent unexpected outages and ensures stable, 24/7 connectivity.
High-power, adaptive PoE for modern business devices
The XMG2230-28HP supports PoE++ on all ports, while the XMG2230-52HP offers a mix of PoE+ and PoE++ for greater deployment flexibility. The series provides adaptive PoE power budget with either internal AC power 700W (28HP)/960W (52HP) or external DC power system 1440W (28HP)/2400W (52HP). It is built for higher capacity, improved efficiency, and reliable operation in demanding environments such as high-performance WiFi, video conferencing, IP surveillance, thin/zero clients, smart building, IoT, and AV applications.

Segment your network more effectively for security
Designed for SME networks, this series of switches supports full L2 feature sets such as VLAN, ACL, port aggregation, and mirroring, along with advanced security to keep your business protected. It also provides essential L3 access features for converged voice, video, and data. With support for static routing, the switches ensure efficient traffic flows across your network, while the built-in DHCP server simplifies device onboarding and reduces IT overhead.
Click. Tap. Done.
Get up and running in minutes with the Nebula mobile app. With just a few simple clicks, our user-friendly step-by-step wizard walks you through the entire installation process, no technical expertise required.
Once connected, the intuitive interface gives you complete control, making it easy to adjust settings, monitor performance and manage your network anytime, anywhere.
Search: Zyxel Nebula Mobile
Powerful, effortless and scalable connectivity.
With Nebula, you can manage your entire network – wireless, switching, security and FWA – through a single centralized cloud platform. Deploy and configure devices quickly and remotely, without the need for extra hardware controllers or software.
Whether you're managing one site or many, Nebula delivers real-time monitoring, instant alerts and complete network visibility – anytime, anywhere.
Scale confidently, simplify operations and stay secure – all through one intuitive platform.
Application Diagram:
Standalone Mode

Nebula Cloud Mode

Specifications:
| Model | XMG2230-28HP | XMG2230-52HP | |||
|---|---|---|---|---|---|
| Description | |||||
| Product name | 24-port 2.5G PoE L3 Access Switch with 4 10G Uplink | 32-port GbE and 16-port 2.5G PoE L3 Access Switch with 4 10G Uplink | |||
| Port Density | |||||
| Total port count | 28 | 52 | |||
| 10M/100M/1G (RJ-45) | - | 32 | |||
| 100M/1G/2.5G Ethernet (RJ-45) | 24 | 16 | |||
| 10-Gigabit SFP+ | 4 | 4 | |||
| PoE | |||||
| PoE ports | 24 | 48 | |||
| Total PoE budget (watts) | Internal AC input: 700 External DC input: 1,440 |
Internal AC input: 960 External DC input: 2,400 |
|||
| IEEE 802.3at PoE+ | - | Yes Port 1 ~ Port 16 |
|||
| IEEE 802.3bt PoE++ (60W) | Yes Port 1 ~ Port 24 (100M/1G/2.5G) |
Yes Port 17 ~ Port 32 (100M/1G) Port 33 ~ Port 48 (100M/1G/2.5G) |
|||
| Performance | |||||
| Switching capacity (Gbps) | 200 | 240 | |||
| Forwarding rate (Mpps) | 148.8 | 166.6 | |||
| Packet buffer (byte) | 2 MB | 2 MB | |||
| MAC address table | 32K | 32K | |||
| Jumbo frame (byte) | 12 KB | 12 KB | |||
| L3 forwarding table (IPv4/IPv6) | Max. 2K IPv4 entries; Max. 2K IPv6 entries |
Max. 2K IPv4 entries; Max. 2K IPv6 entries |
|||
| Routing table | 64 | 64 | |||
| VLAN routing | Yes | Yes | |||
| IP interface (IPv4/IPv6) | 32/32 | 32/32 | |||
| Flash/RAM | 64 MB/1 GB | 64 MB/1 GB | |||
| Power | |||||
| Input | 100 - 240 V AC, 50-57V DC | 100 - 240 V AC, 50-57V DC | |||
| Min. power consumption (watts) Without any port connection | AC: 32.6 / DC: 25.5 | AC: 37.5 / DC: 32 | |||
| Max. power consumption (watts) All ports full load without PoE | AC: 64.7 / DC: 51.5 | AC: 72.4 / DC: 55.5 | |||
| Max. power consumption (watts) All ports full load with PoE | AC: 842.3 / DC: 1519.1 | AC: 1187.9 / DC: 2525 | |||
| Physical Specifications | |||||
| Dimensions (WxDxH)(mm/in.) | 441 x 330 x 44 / 17.36 x 12.99 x 1.73 | 441 x 330 x 44 / 17.36 x 12.99 x 1.73 | |||
| Weight (kg/lb.) | 4.53 / 9.99 | 5.03 / 11.09 | |||
| Included accessories | Power cord Rack mounting |
Power cord Rack mounting |
|||
| ESD/Surge Protections | |||||
| Ethernet port surge protection | 2KV | 2KV | |||
| Power supply surge protection | 2KV Line-GND 1KV Line-Line |
2KV Line-GND 1KV Line-Line |
|||
| ESD protection (air/contact) | 8KV/6KV | 8KV/6KV | |||
| Environmental Specifications | |||||
| Operating Temperature | -20°C to 50°C / -4°F to 122°F | -20°C to 50°C / -4°F to 122°F | |||
| Operating Humidity | 5% to 95% (non-condensing) | 5% to 95% (non-condensing) | |||
| Storage Temperature | -40°C to 70°C / -40°F to 158°F | -40°C to 70°C / -40°F to 158°F | |||
| Storage Humidity | 5% to 95% (non-condensing) | 5% to 95% (non-condensing) | |||
| MTBF (hr @ 25°C) | AC: 554,612.62 / DC: 483,006.55 | AC: 389,089.55 / DC: 401,112.30 | |||
| Heat dissipation (BTU/hr) | 2,856 | 4,153.7 | |||
| Acoustic noise (min/max, dBA) | 28.92 / 48.85 | 41.59 / 63.76 | |||
Software Features
Standard Compliance
- IEEE 802.3z 1000BASE-X*
- IEEE 802.3ab 1000BASE-T Ethernet*
- IEEE 802.3an 10G BASE-T Ethernet*
- IEEE 802.3bz 2.5GBASE-T/5GBASE-T*
- IEEE 802.3ae 10Gbit/s Ethernet over fiber*
- IEEE 802.3af PoE*
- IEEE 802.3at PoE plus*
- IEEE 802.3bt (90W) PoE over 4 pair*
- IEEE 802.3az EEE
- IEEE 802.3x flow control
- IEEE 802.1AB LLDP/LLDP-MED*
- IEEE 802.1Q VLAN tagging
- IEEE 802.1p Class of Service (CoS) prioritization*
- IEEE 802.1X port authentication*
Resilience and Availability
- IEEE 802.1D Spanning Tree Protocol (STP)*
- IEEE 802.1w Rapid Spanning Tree Protocol (RSTP)*
- IEEE 802.1s Multiple Spanning Tree Protocol (MSTP)
- IEEE 802.3ad LACP* (Max # Trunks/ Links per Trunk):
- XMG2230-28HP: 14/8
- XMG2230-52HP: 26/8
- Loop guard* (with broadcast packet detection mechanism)
- Root guard*
- BPDU guard*
- ErrDisable recovery
- MRSTP (Zyxel Proprietary)
- Dual configuration files
- Dual images*
- ZULD
- Physical stacking up to 4 units* (future firmware support)
Traffic Control
- 802.1Q Static VLANs*/Dynamic VLANs: 4MB/4K
- Port-based VLAN
- VLAN isolation
- Vendor ID based VLAN*
- Protocol-based VLAN
- IP subnet-based VLAN
- MAC-based VLAN
- Private VLAN
- Voice VLAN*
- Independent VLAN Learning (IVL)
- VLAN Translation
- VLAN trunking
- VLAN mapping
- IEEE 802.1AD VLAN stacking (QinQ)
- VLAN ingress filtering
- LACP algorithm of source/destination IP or MAC*
- GVRP
- L2PT
Security
- Port security*
- Layer 2 MAC filtering*
- Layer 3 IP filtering
- Layer 4 TCP/UDP socket filtering
- Static MAC forwarding
- Multiple RADIUS servers*
- Multiple TACACS+ servers
- 802.1x VLAN and 802.1p assignment by RADIUS
- Login authentication by RADIUS
- Login authentication by TACACS+
- TACACS+ accounting
- RADIUS accounting
- Authorization on RADIUS
- Compound authentication
- Authorization on TACACS+
- SSH v2*
- SSL
- MAC freeze
- IP source guard (IPv4*/IPv6)
- DHCP snooping
- DHCP Server Guard
- ARP inspection
- ARP freeze
- Anti-ARP scan
- Static IP-MAC-Port binding: 128
- Policy-based security filtering
- Port isolation*
- MAC search*
- Guest VLAN*
- ACL packet filtering IPv4* (on-premise/ Nebula cloud): 256/128
- ACL packet filtering IPv6: 128
- CPU protection
- Interface related trap enable/disable (by port)
- MAC-based authentication per VLAN
- BPDU transparency
- PPPoE relay agent/option82
- WoL/WoL Relay
Quality of Service (QoS)
- No. of hardware queues per port (on-premise/Nebula cloud): 8/6
- Storm control and event log: Broadcast, multicast, unknown unicast (DLF)*
- Port-based rate limiting* (ingress/ egress)
- Rate limiting per IP/TCP/UDP per port
- Policy-based rate limiting
- 802.1p Class of Service (SPQ, WFQ, WRR, hybrid-SPQ combination capable)
- DiffServ (DSCP)
- Multicast/Unknown Unicast (DLF)
Layer 2 Multicast
- L2 multicast*: 1K
- IGMP snooping (v1, v2, v3)*
- IGMP snooping fast leave*
- IGMP snooping immediate leave*
- Configurable IGMP snooping timer and priority*
- IGMP snooping statistics*
- IGMP throttling*
- IGMP filtering*
- IGMP proxy mode & snooping mode selection*
- Multicast load sharing over trunking port
- Static mulitcast
- MVR support
- MLD snooping (MLD v1/v2)
Routing
- Static route (IPv4*/IPv6): 64/64
- DHCP relay
Manageability
- SNMP* v1, v2c, v3
- SNMP trap group
- RMON (1, 2, 3, 9)
- ICMP echo/echo reply
- Syslog*
- Display port utilization*
IPv6 Management
- IPv6 over Ethernet (RFC 2464)
- IPv6 addressing architecture (RFC 4291)
- Dual stack (RFC 4213)
- ICMPv6 (RFC 4443)
- Path MTU (RFC 1981)
- Minimum path MTU size of 1280 (RFC 5095)
- Encapsulation for maximum MTU of 1500
- Neighbor discovery (RFC 4861)
- DHCPv6 snooping
- IPv6 binding- static/dynamic
- Extend Radius server
- DHCPv6 relay
- Default DHCP client mode*
Device Management
- Support NebulaFlex Pro for hybrid mode
- Standalone management by Web interface
- Cloud management by Nebula Control Center*
- Auto configuration recovery (only for cloud mode)
- Zyxel iStacking
- Management through Web, SNMP
- Remote firmware upgrade by FTP/Web/ TFTP
- Configuration saving and retrieving
- Multiple login supported
- Configure clone*
- Custom default Configuration
- Multilevel CLI*
- CLI (Cisco-like)
- DHCP relay per VLAN*
- DHCP client IPv4*/IPv6
- DHCP client option 60
- DHCP option 82*
- Daylight saving*
- DHCP relay MAC proxy
- NTP Support IPv4/IPv6: 3
- Port mirroring*
- Policy-based mirroring
- Mirror CPU
- VLAN-based mirroring
- USB-C console port
- Scheduled PoE*
- PoE default consumption mode*
- Auto PD Recovery*
- Continuous PoE
- LLDP power via MDI
- sFlow
- LED ECO mode to turn-off port LED
- DHCP Server
MIB
- Zyxel Private MIB
- Zyxel Common MIB
- RFC 1066 TCP/IP-based MIB
- RFC 1213, 1157 SNMPv2c/v3 MIB
- RFC 1493, 4188 bridge MIB
- RFC 1643 Ethernet MIB
- RFC 1757 RMON group 1, 2, 3, 9
- RFC 2011, 2012, 2013 SNMPv2 MIB
- RFC 2233 SMIv2 MIB
- RFC 2358 Ethernet-like MIB
- RFC 2674 bridge MIB extension
- RFC 2819, 2925 remote management MIB
- RFC 3621 power Ethernet MIB
- RFC 4022 management information base for transmission control protocol
- RFC 4113 management information base for user datagram protocol
- RFC 4292 IP forwarding table MIB
- RFC 4293 Management Information Base (MIB) for IP
- Cable diagnostic MIB
Certifications
- Safety
- LVD
- BSMI Safety
- EMC
- FCC Part 15 (Class A)
- CE (Class A)
- BSMI EMC
- RoHS compliant
Zyxel One Network
- Discovery of Zyxel switches, APs and gateways
- Centralized and batch configurations
- IP configuration
- IP renew
- Device factory reset
- Device reboot
- Device locating
- Web GUI access
- Firmware upgrade
- Password configuration
- One-click quick association with Zyxel AP Configurator (ZAC)
- Automatic detection of the latest firmware
- Displays device serial number and hardware version
- Cloud mode on/off option for Hybrid series devices
- Intuitive Cloud connection status
Smart Connect
- Discover neighboring devices
- One-click remote management access to the neighboring Zyxel devices
- Reset neighboring devices remotely to factory defaults
- Power cycle neighboring powered devices
Warranty
- Limited life-time warranty**
* Nebula Cloud and Standalone modes supported features. Some Nebula features may need an extra license to work.
** Warranty terms, service availability, and service response times may vary from country or region to country or region.
Documentation:
Download the Zyxel XMG2230 Series Datasheet (PDF).
Pricing Notes:
- Pricing and product availability subject to change without notice.
Our Price: $1,699.99
